Disposable Hero mod.level6h Speed Issues in UADE

Discussion about Amiga / C64 / Demoscene music and the ExoticA music archive. Favourite music, new rips, musicians, demo sounds, audio software. It's all welcome here.

Moderators: XtC, BuZz

Post Reply
User avatar
Enverex
Posts: 2
Joined: Thu Jan 20, 2011 11:20 am
Contact:

Disposable Hero mod.level6h Speed Issues in UADE

Post by Enverex » Thu Jan 20, 2011 12:24 pm

Hi everyone. I hadn't noticed this myself as I hadn't listened to the track but it seems on Disposable Hero's mod.level6h file when played through UADE works fine for about 15 seconds and then slows down to an absolute crawl.

I remember Deliplayer used to do this with the Settlers II music (but UADE worked fine there). I've not noticed it with any other tracks.

The track is mod.level6h on http://www.exotica.org.uk/wiki/Disposable_Hero
The version created by UADE 2.13 is Level6H on http://retrotracks.net/music/83

Any ideas what causes this and how to get around it?

On a random note, thanks to Buzz again for the help with the decoders when I first set up RetroTracks. Although I'm not using them anymore (transcoding every audio format in existence on the fly was a nightmare due to relying on the software to always work, and normally it was madly hacked together for some formats) it did form the basis for the original site.
RetroTracks.net - Classic Video Game Music

User avatar
BuZz
Site Admin
Posts: 568
Joined: Mon Jun 10, 2002 12:52 pm
Location: Didcot, Oxfordshire
Contact:

Re: Disposable Hero mod.level6h Speed Issues in UADE

Post by BuZz » Sun Jan 23, 2011 10:01 pm

From the uade creator himself
yes, it's a vblank issue
uade123 -x vblank mod.level6h works
also, one can fix the problem for that particular song by running: uade123 --set='epopt=vblank' mod.level6h
after that, the song should play fine
~/.uade2/song.conf then contains the line: md5=535bb71fa3d0cc4ba823fae58034fdee epopt=vblank comment mod.level6h

User avatar
Enverex
Posts: 2
Joined: Thu Jan 20, 2011 11:20 am
Contact:

Re: Disposable Hero mod.level6h Speed Issues in UADE

Post by Enverex » Sat Feb 05, 2011 12:04 pm

Cheers for reposting that here for others to see Buzz. Doing what the guys in IRC recommended fixed it.
RetroTracks.net - Classic Video Game Music

Post Reply